Skip to main content
VulnerabilityPublished Updated

CVE-2024-27298: Parse Server literalizeRegexPart SQL Injection

Affects parseSource GCVE Database

0

Not known to be exploited : upgrade to 6.5.0 as a priority.

Data as of 26 Oct 2026, 10:12 UTC

Severity
Critical

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
1.0% chance of exploitation in 30 days – higher than 63% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.5.0

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 31 Mar 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade parse to 6.5.0.

Affected software

ProductAffectedFixed in
Bitnamiparsepkg:bitnami/parseOther threatsAffected
  • <6.5.0
Fixed in
  • 6.5.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade parse-server to version 6.5.0 or later, or 7.0.0 or later, where this vulnerability has been fixed. Applying these official patches fully mitigates the risk. No additional mitigation steps are required if the upgrade is applied.

Description

Parse Server for Node.js / Express contains a critical SQL injection vulnerability (CVE-2024-27298) affecting configurations using PostgreSQL. This flaw allows SQL injection attacks via the literalizeRegexPart component. The issue has been fixed in versions 6.5.0 and 7.0.0.

References

Community reviews

Loading reviews…