Skip to main content
VulnerabilityPublished Updated

CVE-2025-15036: mlflow/mlflow · Path Traversal Vulnerability

Affects mlflowSource GCVE Database

0
Authoritative record:CVE-2025-15036· Critical 9.6

Not known to be exploited · CVSS 9.6 Critical : upgrade to 3.9.0 as a priority.

Data as of 26 Oct 2026, 14:05 UTC

CVSS 3.0 base score
9.6Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 47% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.9.0
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade mlflow to 3.9.0.

Affected software

ProductAffectedFixed in
Bitnamimlflowpkg:bitnami/mlflowOther threatsAffected
  • <3.9.0
Fixed in
  • 3.9.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied to upgrade mlflow to version 3.9.0 or later. The vendor advisory and GitHub commit provide the official fix. No additional mitigations are specified or required beyond applying the patch.

Description

A path traversal vulnerability exists in the extract_archive_to_dir function of mlflow before version 3.9.0. This flaw allows an attacker controlling a tar.gz archive to overwrite arbitrary files on the system, potentially leading to privilege escalation or sandbox escape in multi-tenant or shared cluster environments. The vulnerability is critical and has an available patch.

References

Community reviews

Loading reviews…