Payload CMS 3.72.0 · Blind SQL Injection
Affects payloadSource Exploit-DB RSS Feed
Public exploit available (Exploit-DB) · CVSS 9.8 Critical : upgrade to 3.73.0 as a priority.
Data as of 3 Nov 2026, 10:57 UTC
- EPSS
- 0.8% chance of exploitation in 30 days – higher than 57% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.73.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
t = 0 is the CVE’s publication on cve.org
Disclosed: evidence found.
CVE published 6 Feb 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
Timeline
CVE ID reserved
by GitHub, Inc.
, 4 days before disclosure
CVE published
on cve.org
, t = 0
In Threat Radar
record ingested
, 23 minutes after disclosure
First Exploit-DB entry (opens in a new tab)
Payload CMS 3.72.0 - Blind SQL Injection
, 207 days after disclosure
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Upgrade payload to 3.73.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
npmpayloadpkg:npm/payloadOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in Payload CMS version 3.73.0 and later. Users should upgrade to version 3.73.0 or newer to remediate this vulnerability. No vendor advisory was provided, but the versioning indicates that upgrading beyond 3.72.0 addresses the issue. Until upgrading, avoid using untrusted input in 'where' filters on JSON or RichText fields with Drizzle adapters.
Description
Payload CMS versions prior to 3.73.0 contain a blind SQL injection vulnerability in the processing of 'where' filters on JSON or RichText fields using the Drizzle database adapters. This vulnerability allows attacker-controlled JSON filter input to manipulate generated JSONPath expressions, potentially exposing sensitive data. Exploit code is publicly available demonstrating this issue on Payload CMS 3.72.0 with PostgreSQL 15.
Indicators of compromise
Exploit source code
# Exploit Title: Payload CMS 3.72.0 - Blind SQL Injection
# Google Dork: N/A
# Date: 2026-08-01
# Exploit Author: cardosource
# Vendor Homepage: https://payloadcms.com/
# Software Link: https://github.com/payloadcms/payload
# Version: < 3.73.0
# Tested on: Docker - Node.js v24.18.1 (Recommended LTS) + Payload CMS 3.72.0 + PostgreSQL 15
# CVE: CVE-2026-25544
#
# Description:
# Payload CMS versions prior to 3.73.0 contain a Blind SQL Injection
# vulnerability when processing `where` filters on JS…