CVE-2026-71537: paymenter/paymenter · Paymenter has a credit-refund double-spend race condition in service downgrade (doUpgrade)
Affects paymenter/paymenterSource GCVE Database
Not known to be exploited · CVSS 6.5 Medium : upgrade to 1.5.7 when convenient.
Data as of 2 Nov 2026, 22:58 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 25% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.5.7
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 18 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.
What to do
Upgrade paymenter/paymenter to 1.5.7.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Packagistpaymenter/paymenter | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available for this vulnerability. Operators should upgrade to Paymenter version 1.5.7 or later, where the issue is fixed by implementing proper transactional safety and database locking to serialize concurrent downgrade requests. Until patched, no reliable workaround is described. Users should apply the official fix to prevent exploitation.
Description
Paymenter payment platform versions prior to 1.5.7 contain a race condition in the service downgrade process that allows authenticated users to trigger multiple refunds for a single downgrade. This occurs because the downgrade logic lacks transactional safety and proper database locking, enabling concurrent requests to bypass concurrency checks and inflate user credit balances. The inflated credits can be used immediately for future payments or service provisioning, causing direct financial loss to the operator.
References
- github.com/Paymenter/Paymenter/security/advisories/GHSA-5gmm-hjfj-8ff7 (opens in a new tab)
- github.com/Paymenter/Paymenter/commit/a42e7f8bafce054ad70de3a2c2ac94d13579f41b (opens in a new tab)
- github.com/Paymenter/Paymenter (opens in a new tab)
- github.com/Paymenter/Paymenter/releases/tag/v1.5.7 (opens in a new tab)