Skip to main content
VulnerabilityPublished Updated

CVE-2026-28804: Pdfly · pypdf vulnerable to inefficient decoding of ASCIIHexDecode streams

Affects pdflySource GCVE Database

0
Authoritative record:CVE-2026-28804· Medium 6.9

Not known to be exploited · CVSS 6.9 Medium : upgrade to 0.5.1_10 when convenient.

Data as of 26 Oct 2026, 18:58 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 0.5.1_10
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade pdfly to 0.5.1_10.

Affected software

ProductAffectedFixed in
Homebrewpdflypkg:brew/pdflyOther threatsAffected
  • >=0.4.0 <0.5.1_10
Fixed in
  • 0.5.1_10

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

### Impact An attacker who uses this vulnerability can craft a PDF which leads to long runtimes. This requires accessing a stream which uses the `/ASCIIHexDecode` filter. ### Patches This has been fixed in [pypdf==6.7.5](https://github.com/py-pdf/pypdf/releases/tag/6.7.5). ### Workarounds If you cannot upgrade yet, consider applying the changes from PR [#3666](https://github.com/py-pdf/pypdf/pull/3666).

References

Community reviews

Loading reviews…