Skip to main content
CVE-2026-4177VulnerabilityPublished Updated

SUSE perl-yaml-syck · security update for perl-YAML-Syck

Affects SUSE perl-yaml-syckSource GCVE Database

0
Compare
Authoritative record:CVE-2026-4177· Critical 9.1

Not known to be exploited · CVSS 9.1 Critical : upgrade SUSE perl-yaml-syck to 1.37 as a priority.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 3.1 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 38% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.37
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade redhat/perl-yaml-syck to 1.37.

Affected software

ProductAffectedFixed in
Redhatredhat/perl-yaml-syckpkg:deb/redhat/perl-yaml-syckOther threatsAffected
  • <1.37
Fixed in
  • 1.37

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released official security updates for perl-YAML-Syck in Red Hat Enterprise Linux 7 Extended Life Cycle Support to fix these vulnerabilities. Users should apply these updates promptly. The vendor advisory does not indicate that no action is required or that the issue is already mitigated without updates. Patch status is confirmed by Red Hat advisories RHSA-2026:6470 and RHSA-2026:8311. No cloud service is involved; remediation requires applying vendor patches.

Description

CVE-2026-4177 is a critical heap-based buffer overflow vulnerability in YAML::Syck versions through 1.36 for Perl. The flaw occurs when class names exceed the initial 512-byte allocation in the YAML emitter. Additional issues include a base64 decoder reading past buffer ends on trailing newlines, corruption of shared node data due to strtok mutating type IDs, and a memory leak when adding anchors to nodes that already have one. Red Hat has issued security advisories and updates addressing these vulnerabilities.

References

Community reviews

Loading reviews…