Skip to main content
CVE-2024-5585VulnerabilityPublished Updated

CVE-2024-5585: Php · Command injection via array-ish $command parameter of proc_open() (bypass CVE-2024-1874 fix)

Affects phpSource GCVE Database

0

Mentioned vulnerabilities

Not known to be exploited · 28% EPSS · fixed in 8.3.8 : patch php soon.

Data as of 26 Oct 2026, 06:26 UTC

Severity
High

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
28.8% chance of exploitation in 30 days – higher than 98% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.3.8, 8.2.20, 8.1.29

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 12 Jun 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade php to 8.3.8, 8.2.20 or 8.1.29.

Affected software

ProductAffectedFixed in
Bitnamiphppkg:bitnami/phpOther threatsAffected
  • <8.1.29
  • >=8.2.0 <8.2.20
  • >=8.3.0 <8.3.8
Fixed in
  • 8.1.29
  • 8.2.20
  • 8.3.8

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available for this vulnerability. Users should upgrade to PHP versions 8.1.29 or later, 8.2.20 or later, and 8.3.8 or later to mitigate this issue. Applying these official fixes will prevent the bypass of the previous CVE-2024-1874 patch. No additional mitigation steps are indicated by the vendor advisory.

Description

CVE-2024-5585 is a command injection vulnerability in PHP affecting versions before 8.1.29, 8.2.20, and 8.3.8. It bypasses the fix for CVE-2024-1874 when the command name includes trailing spaces. The vulnerability arises from insufficient escaping in proc_open() when used with array syntax, allowing an attacker controlling command arguments to execute arbitrary commands on Windows shells.

References

Community reviews

Loading reviews…