Skip to main content
CVE-2026-59882VulnerabilityPublished

Php guzzlehttp psr7: Prior to 2.12.3, Uri::assertValidHost() does not reject URI host components containing authority

Affects php-guzzlehttp-psr7Source GCVE Database

0
Authoritative record:CVE-2026-59882· Medium 4.2

Not known to be exploited · CVSS 4.2 Medium · fixed in 2.12.3 : update php-guzzlehttp-psr7 when convenient.

Data as of 26 Oct 2026, 12:55 UTC

CVSS 3.1 base score
4.2Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 24% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.12.3
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSphp-guzzlehttp-psr7pkg:deb/ubuntu/php-guzzlehttp-psr7@2.8.0-2?arch=source&distro=resoluteOther threatsAffected
  • =2.7.1-1
  • =2.8.0-1
  • =2.8.0-2
Fixed in–
Ubuntu 25.10php-guzzlehttp-psr7pkg:deb/ubuntu/php-guzzlehttp-psr7@2.7.1-1?arch=source&distro=questingOther threatsAffected
  • =2.7.0-3
  • =2.7.1-1
Fixed in–
Ubuntu 24.04 LTSphp-guzzlehttp-psr7pkg:deb/ubuntu/php-guzzlehttp-psr7@2.6.2-1?arch=source&distro=nobleOther threatsAffected
  • =2.6.0-1
  • =2.6.1-1
  • =2.6.2-1
Fixed in–
Ubuntu Pro 22.04 LTSphp-guzzlehttp-psr7pkg:deb/ubuntu/php-guzzlehttp-psr7@1.8.3-1ubuntu0.1~esm1?arch=source&distro=esm-apps/jammyOther threatsAffected
  • =1.7.0-1
  • =1.8.3-1
  • =1.8.3-1ubuntu0.1~esm1
Fixed in–
Ubuntu 20.04 LTSphp-guzzlehttp-psr7pkg:deb/ubuntu/php-guzzlehttp-psr7@1.4.2-0.1+deb10u2build0.20.04.1?arch=source&distro=focalOther threatsAffected
  • =1.4.2-0.1
  • =1.4.2-0.1+deb10u2build0.20.04.1
Fixed in–
Ubuntu 16.04 LTSphp-guzzlehttp-psr7pkg:deb/ubuntu/php-guzzlehttp-psr7@1.2.2-1ubuntu1?arch=source&distro=xenialOther threatsAffected
  • 1.1.0-1 – 1.2.2-1ubuntu1
6 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade to guzzlehttp/psr7 version 2.12.3 or later, where this vulnerability is resolved. No other mitigation or temporary workaround is indicated.

Description

A vulnerability exists in the guzzlehttp/psr7 PHP library prior to version 2.12.3 in the Uri::assertValidHost() function. This function does not properly reject URI host components containing authority delimiters, embedded ports, or malformed IPv6 brackets. Consequently, the Uri::getHost() method may return an incorrect host value that differs from the actual URI authority, which could affect security or routing decisions. The issue is fixed in version 2.12.3.

References

Community reviews

Loading reviews…