Php horde vfs: Horde Virtual File System (VFS) API before 3.0.1 contains an OS command injection vulnerability in the
Affects php-horde-vfsSource GCVE Database
Not known to be exploited · CVSS 7.7 High · fixed in 3.0.1 : patch php-horde-vfs soon.
Data as of 26 Oct 2026, 12:29 UTC
- EPSS
- 3.2% chance of exploitation in 30 days – higher than 88% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.0.1
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 8 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 18.04 LTSphp-horde-vfspkg:deb/ubuntu/php-horde-vfs@2.4.0-1ubuntu1?arch=source&distro=bionicOther threats | Affected
| Fixed in– |
Ubuntu 16.04 LTSphp-horde-vfspkg:deb/ubuntu/php-horde-vfs@2.3.1-1ubuntu1?arch=source&distro=xenialOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in Horde VFS API version 3.0.1. Users should upgrade to version 3.0.1 or later to remediate this vulnerability. Until then, restrict access to authenticated users and monitor for suspicious file operation activities. No vendor advisory or official patch links were provided, so confirm patch availability from the vendor or trusted repositories.
Description
CVE-2026-60102 is a command injection vulnerability in the Horde Virtual File System (VFS) API's Horde_Vfs_Smb driver before version 3.0.1. It occurs because the _escapeShellCommand() method fails to properly sanitize command substitution sequences in user-controlled filenames. Authenticated attackers can exploit this flaw by providing malicious filenames during file operations, resulting in arbitrary shell command execution on the underlying system.
References
- ubuntu.com/security/CVE-2026-60102 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-60102 (opens in a new tab)
- github.com/horde/Vfs/pull/10 (opens in a new tab)
- github.com/horde/Vfs/commit/41f74b4acfc144e09013d04dd121e0a5da808361 (opens in a new tab)
- github.com/horde/Vfs/releases/tag/v3.0.1 (opens in a new tab)
- vulncheck.com/advisories/horde-vfs-os-command-injection-via-horde-vfs-smb-driver (opens in a new tab)