Skip to main content
VulnerabilityPublished

CVE-2026-46627: Php twig · Twig is a template language for PHP

Affects php-twigSource GCVE Database

0
Authoritative record:CVE-2026-46627· High 7.1

Not known to be exploited · CVSS 7.1 High · fixed in 3.26.0 : patch php-twig soon.

Data as of 26 Oct 2026, 11:42 UTC

CVSS 4.0 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 45% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.26.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 26.10php-twigpkg:deb/ubuntu/php-twig?arch=source&distro=stonkingOther threatsAffected
  • =3.23.0-2build7
  • =3.27.1-1
  • =3.28.0-1
Fixed in–
Ubuntu Pro 26.04 LTSphp-twigpkg:deb/ubuntu/php-twig?arch=source&distro=esm-apps/resoluteOther threatsAffected
  • 3.20.0-2ubuntu1 – 3.23.0-2ubuntu0.1~esm1
4 affected builds
Fixed in–
Ubuntu 25.10php-twigpkg:deb/ubuntu/php-twig?arch=source&distro=questingOther threatsAffected
  • =3.20.0-2ubuntu1
Fixed in–
Ubuntu Pro 24.04 LTSphp-twigpkg:deb/ubuntu/php-twig?arch=source&distro=esm-apps/nobleOther threatsAffected
  • 3.7.0-1 – 3.8.0-2ubuntu1+esm1
6 affected builds
Fixed in–
Ubuntu Pro 22.04 LTSphp-twigpkg:deb/ubuntu/php-twig?arch=source&distro=esm-apps/jammyOther threatsAffected
  • 3.3.2-1ubuntu3 – 3.3.8-2ubuntu4+esm2
7 affected builds
Fixed in–
Ubuntu Pro 20.04 LTSphp-twigpkg:deb/ubuntu/php-twig?arch=source&distro=esm-apps/focalOther threatsAffected
  • 2.11.3-2 – 2.12.5-1ubuntu0.1~esm2
7 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade to Twig version 3.26.0 or later, where the sandbox behavior is clarified and this issue is addressed. No other specific mitigations are indicated. Patch status is confirmed by the version update to 3.26.0.

Description

Twig, a PHP template language, has a vulnerability in its sandbox prior to version 3.26.0 that allows untrusted templates to cause resource exhaustion by consuming excessive CPU, memory, or wall-clock time. This issue is addressed in version 3.26.0 by clarifying that the sandbox does not protect against resource exhaustion.

References

Community reviews

Loading reviews…