CVE-2026-47732: Php twig · Twig is a template language for PHP
Affects php-twigSource GCVE Database
Not known to be exploited · CVSS 7.1 High · fixed in 3.26.0 : patch php-twig soon.
Data as of 26 Oct 2026, 10:12 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 34% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.26.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 14 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.10php-twigpkg:deb/ubuntu/php-twig?arch=source&distro=stonkingOther threats | Affected
| Fixed in– |
Ubuntu Pro 26.04 LTSphp-twigpkg:deb/ubuntu/php-twig?arch=source&distro=esm-apps/resoluteOther threats | Affected
| Fixed in– |
Ubuntu 25.10php-twigpkg:deb/ubuntu/php-twig?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu Pro 24.04 LTSphp-twigpkg:deb/ubuntu/php-twig?arch=source&distro=esm-apps/nobleOther threats | Affected
| Fixed in– |
Ubuntu Pro 22.04 LTSphp-twigpkg:deb/ubuntu/php-twig?arch=source&distro=esm-apps/jammyOther threats | Affected
| Fixed in– |
Ubuntu Pro 20.04 LTSphp-twigpkg:deb/ubuntu/php-twig?arch=source&distro=esm-apps/focalOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Twig to version 3.26.0 or later to remediate this vulnerability. No other mitigation is indicated by the vendor advisory.
Description
Twig versions prior to 3.26.0 contain a vulnerability where certain language constructs cause PHP string coercion on Stringable objects without proper security checks. This flaw allows sandboxed template authors to invoke the __toString() method on objects accessible in the render context. The issue is resolved in Twig version 3.26.0.
References
- ubuntu.com/security/CVE-2026-47732 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-47732 (opens in a new tab)
- symfony.com/blog/cve-2026-47732-sandbox-multiple-tostring-policy-bypasses-via-unguarded-string-coercion-points (opens in a new tab)
- github.com/twigphp/Twig/commit/447d0b2331e01b8fc6e08119ac984e1ef50caef9 (opens in a new tab)
- github.com/twigphp/Twig/releases/tag/v3.26.0 (opens in a new tab)
- github.com/twigphp/Twig/security/advisories/GHSA-pr2w-4gpj-cpq4 (opens in a new tab)