Skip to main content
VulnerabilityPublished

CVE-2026-48807: Php twig · Twig is a template language for PHP

Affects php-twigSource GCVE Database

0

Not known to be exploited · CVSS 9.1 Critical · fixed in 3.27.0 : patch php-twig as a priority.

Data as of 26 Oct 2026, 10:12 UTC

CVSS 3.1 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 30% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.27.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 26.10php-twigpkg:deb/ubuntu/php-twig?arch=source&distro=stonkingOther threatsAffected
  • =3.23.0-2build7
  • =3.27.1-1
  • =3.28.0-1
Fixed in–
Ubuntu Pro 26.04 LTSphp-twigpkg:deb/ubuntu/php-twig?arch=source&distro=esm-apps/resoluteOther threatsAffected
  • 3.20.0-2ubuntu1 – 3.23.0-2ubuntu0.1~esm1
4 affected builds
Fixed in–
Ubuntu 25.10php-twigpkg:deb/ubuntu/php-twig?arch=source&distro=questingOther threatsAffected
  • =3.20.0-2ubuntu1
Fixed in–
Ubuntu Pro 24.04 LTSphp-twigpkg:deb/ubuntu/php-twig?arch=source&distro=esm-apps/nobleOther threatsAffected
  • 3.7.0-1 – 3.8.0-2ubuntu1+esm1
6 affected builds
Fixed in–
Ubuntu Pro 22.04 LTSphp-twigpkg:deb/ubuntu/php-twig?arch=source&distro=esm-apps/jammyOther threatsAffected
  • 3.3.2-1ubuntu3 – 3.3.8-2ubuntu4+esm2
7 affected builds
Fixed in–
Ubuntu Pro 20.04 LTSphp-twigpkg:deb/ubuntu/php-twig?arch=source&distro=esm-apps/focalOther threatsAffected
  • 2.11.3-2 – 2.12.5-1ubuntu0.1~esm2
7 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Twig to version 3.27.0 or later, where this vulnerability is fixed. No other mitigation is indicated by the vendor advisory.

Description

Twig, a PHP template language, has a vulnerability in versions prior to 3.27.0 where sandbox __toString() checks do not fully cover Traversable values passed to certain filters and operators. This allows Stringable objects within these values to be coerced to strings without sandbox policy enforcement. The issue is fixed in version 3.27.0.

References

Community reviews

Loading reviews…