Skip to main content
CVE-2026-91767VulnerabilityPublished Updated

Php7.0: php_openssl_matches_wildcard_name()

Affects php7.0Source GCVE Database

0
Authoritative record:CVE-2026-91767· Medium 6.5

Not known to be exploited · CVSS 6.5 Medium · fixed in 7.0.33-0ubuntu0.16.04.16+esm21 : update php7.0 when convenient.

Data as of 28 Oct 2026, 22:28 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 7.0.33-0ubuntu0.16.04.16+esm21, 7.2.24-0ubuntu0.18.04.17+esm13, 7.4.3-4ubuntu2.29+esm4 +4
CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 25 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 26.10php8.5pkg:deb/ubuntu/php8.5?arch=source&distro=stonkingOther threatsAffected
  • <8.5.9-0ubuntu2
Fixed in
  • 8.5.9-0ubuntu2
Ubuntu 26.04 LTSphp8.5pkg:deb/ubuntu/php8.5?arch=source&distro=resoluteOther threatsAffected
  • <8.5.4-0ubuntu1.4
Fixed in
  • 8.5.4-0ubuntu1.4
Ubuntu 24.04 LTSphp8.3pkg:deb/ubuntu/php8.3?arch=source&distro=nobleOther threatsAffected
  • <8.3.6-0ubuntu0.24.04.12
Fixed in
  • 8.3.6-0ubuntu0.24.04.12
Ubuntu 22.04 LTSphp8.1pkg:deb/ubuntu/php8.1?arch=source&distro=jammyOther threatsAffected
  • <8.1.2-1ubuntu2.27
Fixed in
  • 8.1.2-1ubuntu2.27
Ubuntu Pro 20.04 LTSphp7.4pkg:deb/ubuntu/php7.4?arch=source&distro=esm-infra/focalOther threatsAffected
  • <7.4.3-4ubuntu2.29+esm4
Fixed in
  • 7.4.3-4ubuntu2.29+esm4
Ubuntu Pro 18.04 LTSphp7.2pkg:deb/ubuntu/php7.2?arch=source&distro=esm-infra/bionicOther threatsAffected
  • <7.2.24-0ubuntu0.18.04.17+esm13
Fixed in
  • 7.2.24-0ubuntu0.18.04.17+esm13

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

php_openssl_matches_wildcard_name() in ext/openssl/xp_ssl.c underflows the length argument passed to memchr() when a TLS server certificate presents a wildcard name whose literal characters are together longer than the hostname being verified. A malicious server presenting such a certificate makes the PHP client read up to SIZE_MAX bytes past the end of a heap allocation. The path is reachable from any default client stream, because verify_peer_name is enabled by default.

References

Community reviews

Loading reviews…