Skip to main content
VulnerabilityPublished Updated

CVE-2025-1218: php8.5, php8.3, php8.1, php7.4, php7.2, php7.0, php5 vulnerabilities

Affects php5Source GCVE Database

0

Mentioned vulnerabilities

Authoritative record:CVE-2025-1218· Low 3.4

Not known to be exploited · CVSS 3.4 Low · fixed in 5.5.9+dfsg-1ubuntu4.29+esm17 : update php5 when convenient.

Data as of 27 Oct 2026, 06:42 UTC

CVSS 3.1 base score
3.4Low
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 5.5.9+dfsg-1ubuntu4.29+esm17, 7.0.33-0ubuntu0.16.04.16+esm21, 7.2.24-0ubuntu0.18.04.17+esm13 +5
CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:C/C:L/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 25 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 26.10php8.5pkg:deb/ubuntu/php8.5?arch=source&distro=stonkingOther threatsAffected
  • <8.5.9-0ubuntu2
Fixed in
  • 8.5.9-0ubuntu2
Ubuntu 26.04 LTSphp8.5pkg:deb/ubuntu/php8.5?arch=source&distro=resoluteOther threatsAffected
  • <8.5.4-0ubuntu1.4
Fixed in
  • 8.5.4-0ubuntu1.4
Ubuntu 24.04 LTSphp8.3pkg:deb/ubuntu/php8.3?arch=source&distro=nobleOther threatsAffected
  • <8.3.6-0ubuntu0.24.04.12
Fixed in
  • 8.3.6-0ubuntu0.24.04.12
Ubuntu 22.04 LTSphp8.1pkg:deb/ubuntu/php8.1?arch=source&distro=jammyOther threatsAffected
  • <8.1.2-1ubuntu2.27
Fixed in
  • 8.1.2-1ubuntu2.27
Ubuntu Pro 20.04 LTSphp7.4pkg:deb/ubuntu/php7.4?arch=source&distro=esm-infra/focalOther threatsAffected
  • <7.4.3-4ubuntu2.29+esm4
Fixed in
  • 7.4.3-4ubuntu2.29+esm4
Ubuntu Pro 18.04 LTSphp7.2pkg:deb/ubuntu/php7.2?arch=source&distro=esm-infra/bionicOther threatsAffected
  • <7.2.24-0ubuntu0.18.04.17+esm13
Fixed in
  • 7.2.24-0ubuntu0.18.04.17+esm13

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

It was discovered that PHP did not properly validate the size of MySQL server packets in the mysqlnd driver. A malicious server could possibly use this issue to cause PHP to crash, resulting in a denial of service. This issue was only addressed in Ubuntu 20.04 LTS, Ubuntu 22.04 LTS, Ubuntu 24.04 LTS, Ubuntu 26.04 LTS, and Ubuntu 26.10. (CVE-2025-1218) It was discovered that PHP incorrectly handled response buffer sizes in the SOAP HTTP client. A malicious server could possibly use this issue to cause PHP to crash, resulting in a denial of service, or execute arbitrary code. (CVE-2025-14181) It was discovered that PHP incorrectly handled certain TAR archive headers in the Phar extension. An attacker could possibly use this issue to inject arbitrary files into a crafted archive. (CVE-2026-6103) It was discovered that PHP did not limit recursion depth when parsing certain SOAP requests. A remote attacker could possibly use this issue to cause PHP to crash, resulting in a denial of service. (CVE-2026-91765) It was discovered that PHP incorrectly handled authentication headers when following HTTP redirects. A remote attacker could possibly use this issue to obtain sensitive information. (CVE-2026-91766) It was discovered that PHP incorrectly handled wildcard names in TLS server certificates. A malicious server could possibly use this issue to cause PHP to crash, resulting in a denial of service. This issue did not affect Ubuntu 14.04 LTS. (CVE-2026-91767) It was discovered that PHP incorrectly validated IPv6 client addresses in the FastCGI client access check. A remote attacker could possibly use this issue to bypass access restrictions. This issue did not affect Ubuntu 14.04 LTS. (CVE-2026-91768) It was discovered that PHP incorrectly performed TLS peer name verification. A remote attacker could possibly use this issue to impersonate a trusted server. (CVE-2026-91769) It was discovered that PHP incorrectly handled certain stream filter options. An attacker could possibly use this issue to obtain sensitive information. (CVE-2026-92842) It was discovered that PHP incorrectly handled empty Location headers when following HTTP redirects. A malicious server could possibly use this issue to redirect the client to an unintended location. This issue did not affect Ubuntu 14.04 LTS. (CVE-2026-93682)

References

Community reviews

Loading reviews…