Skip to main content
CVE-2026-42310VulnerabilityPublished Updated

Pillow: From version 4.2.0 to before version 12.2.0, an attacker can supply a malicious PDF that causes the process to

Affects pillowSource GCVE Database

0
Compare
Authoritative record:CVE-2026-42310· Medium 5.1

Not known to be exploited · CVSS 5.1 Medium · fixed in 9.0.1-1ubuntu0.4 : update pillow when convenient.

Data as of 4 Nov 2026, 05:01 UTC

CVSS 4.0 base score
5.1Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 9.0.1-1ubuntu0.4, 10.2.0-1ubuntu1.2, 11.3.0-1ubuntu1.3 +1
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 9 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSpillowpkg:deb/ubuntu/pillow?arch=source&distro=resoluteOther threatsAffected
  • <12.1.1-2ubuntu1.2
Fixed in
  • 12.1.1-2ubuntu1.2
Ubuntu 25.10pillowpkg:deb/ubuntu/pillow?arch=source&distro=questingOther threatsAffected
  • <11.3.0-1ubuntu1.3
Fixed in
  • 11.3.0-1ubuntu1.3
Ubuntu 24.04 LTSpillowpkg:deb/ubuntu/pillow?arch=source&distro=nobleOther threatsAffected
  • <10.2.0-1ubuntu1.2
Fixed in
  • 10.2.0-1ubuntu1.2
Ubuntu 22.04 LTSpillowpkg:deb/ubuntu/pillow?arch=source&distro=jammyOther threatsAffected
  • <9.0.1-1ubuntu0.4
Fixed in
  • 9.0.1-1ubuntu0.4
Ubuntu Pro 20.04 LTSpillowpkg:deb/ubuntu/pillow?arch=source&distro=esm-infra/focalOther threatsAffected
  • 6.1.0-1 – 7.0.0-4ubuntu0.9+esm1
15 affected builds
Fixed in–
Ubuntu Pro 20.04 LTSpillow-python2pkg:deb/ubuntu/pillow-python2?arch=source&distro=esm-apps/focalOther threatsAffected
  • 6.2.1-3 – 6.2.1-3ubuntu0.1~esm2
4 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in Pillow version 12.2.0 and in updated Ubuntu packages: python3-pil versions 9.0.1-1ubuntu0.4 (22.04 LTS), 10.2.0-1ubuntu1.2 (24.04 LTS), 11.3.0-1ubuntu1.3 (25.10), and 12.1.1-2ubuntu1.2 (26.04 LTS). Users should update to these fixed versions or later to remediate the issue. Standard system updates will apply the necessary patches.

Description

Pillow versions from 4.2.0 up to but not including 12.2.0 contain a vulnerability where processing a maliciously crafted PDF can cause the process to hang indefinitely, consuming 100% CPU and making the application unresponsive. This denial of service issue has been addressed in version 12.2.0. The vulnerability affects multiple Ubuntu package versions and has a medium severity rating with a CVSS score of 5.5.

References

Community reviews

Loading reviews…