Skip to main content
CVE-2026-32688VulnerabilityPublished

Plug cowboy: Plug.Cowboy vulnerable to unauthenticated remote DoS via HTTP/2 `:scheme` atom-table exhaustion

Affects plug_cowboySource GCVE Database

0
Authoritative record:CVE-2026-32688· High 8.7

Not known to be exploited · CVSS 8.7 High : upgrade to 2.8.1 soon.

Data as of 27 Oct 2026, 01:51 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.8.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade plug_cowboy to 2.8.1.

Affected software

ProductAffectedFixed in
Hexplug_cowboyAffected
  • >=2.0.0 <2.8.1
Fixed in
  • 2.8.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should update plug_cowboy to version 2.8.1 or later to mitigate this vulnerability. If HTTP/2 endpoints are exposed directly, applying this update is critical. Use of proxies that downgrade HTTP/2 to HTTP/1.1 internally may reduce exposure, but patching is the recommended and definitive mitigation.

Description

Plug.Cowboy versions from 2.0.0 up to but not including 2.8.1 are vulnerable to an unauthenticated remote denial-of-service attack via HTTP/2. An attacker can exhaust the Erlang VM's atom table by sending crafted HTTP/2 requests, causing the entire VM to crash. This affects applications using Plug.Cowboy with HTTP/2 enabled, including Phoenix applications if they expose HTTP/2 endpoints directly without a proxy or with certain proxy configurations. The vulnerability is fixed in version 2.8.1.

References

Community reviews

Loading reviews…