Skip to main content
VulnerabilityPublished Updated

CVE-2026-55697: pnpm · Repository-controlled configDependencies can select a pacquet native install engine

Affects pnpmSource GCVE Database

0
Compare

Not known to be exploited · CVSS 7.5 High : upgrade to 11.5.3 soon.

Data as of 30 Oct 2026, 05:15 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 11.5.3
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade pnpm to 11.5.3.

Affected software

ProductAffectedFixed in
Homebrewpnpmpkg:brew/pnpmOther threatsAffected
  • >=4.0.2 <11.5.3
Fixed in
  • 11.5.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

pnpm is a package manager. Prior to 10.34.2 and 11.5.3, pnpm can install configDependencies declared in pnpm-workspace.yaml before command dispatch. Before the patch, a repository could declare pacquet or @pnpm/pacquet as a config dependency and pnpm treated that repository-controlled dependency as an install-engine opt-in. During install, pnpm resolved a platform-specific @pacquet/<platform>-<arch>/pacquet binary from node_modules/.pnpm-config/<packageName> and spawned it as the developer or CI user. This vulnerability is fixed in 10.34.2 and 11.5.3.

References

Community reviews

Loading reviews…