Skip to main content
VulnerabilityPublished Updated

CVE-2024-53899: Poetry · virtualenv allows command injection through activation scripts for a virtual environment

Affects poetrySource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2024-53899· High 8.4

Not known to be exploited · CVSS 8.4 High : upgrade to 1.8.4 or 1.2.2_1 soon.

Data as of 30 Oct 2026, 08:29 UTC

CVSS 3.1 base score
8.4High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.8.4, 1.2.2_1
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 Nov 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade poetry to 1.8.4 or 1.2.2_1.

Affected software

ProductAffectedFixed in
Homebrewpoetrypkg:brew/poetryOther threatsAffected
  • >=1.1.0 <1.2.2_1
  • >=1.8.0 <1.8.4
Fixed in
  • 1.2.2_1
  • 1.8.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Apply the official patches by upgrading Poetry to version 1.2.2_1 or later, or 1.8.4 or later, where the vulnerability is fixed. Since patchAvailable is true and fixedVersions are known, updating to these versions fully mitigates the risk. No additional mitigation steps are indicated by the vendor advisory.

Description

A command injection vulnerability exists in virtualenv versions before 20.26.6, affecting Poetry's virtual environment activation scripts. The issue arises because magic template strings are not properly quoted during replacement, allowing arbitrary command execution. This vulnerability is distinct from CVE-2024-9287. It affects Poetry versions >=1.1.0 <1.2.2_1 and >=1.8.0 <1.8.4. A fix is available in versions 1.2.2_1 and 1.8.4.

References

Community reviews

Loading reviews…