Skip to main content
CVE-2024-22421VulnerabilityPublished Updated

CVE-2024-22421: JupyterLab vulnerable to potential authentication and CSRF tokens leak

Affects jupyterlabSource GCVE Database

0

Not known to be exploited · CVSS 7.6 High : upgrade to 4.0.11 or 3.6.7 soon.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
7.6High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 51% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.0.11, 3.6.7, 4.6.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade jupyterlab to 4.0.11 or 3.6.7; jupyterlab to 4.6.3.

Affected software

ProductAffectedFixed in
Bitnamijupyterlabpkg:bitnami/jupyterlabOther threatsAffected
  • <3.6.7
  • >=4.0.0 <4.0.11
Fixed in
  • 3.6.7
  • 4.0.11
Homebrewjupyterlabpkg:brew/jupyterlabOther threatsAffected
  • <4.6.3
Fixed in
  • 4.6.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available. Users should upgrade JupyterLab to versions 3.6.7, 4.0.11, or later (including 4.1.0b2). Additionally, upgrading jupyter-server to version 2.7.2 or newer is required to address the redirect vulnerability that causes token leakage. No other workarounds have been identified.

Description

JupyterLab versions prior to 3.6.7, between 4.0.0 and before 4.0.11, and before 4.6.3 are vulnerable to a flaw that may expose users' Authorization and XSRF tokens if they click on a malicious link while running an older jupyter-server version. This vulnerability can lead to token leakage, potentially compromising user sessions. Patches have been released in JupyterLab 3.6.7, 4.0.11, and 4.1.0b2. Users are advised to upgrade jupyter-server to version 2.7.2 or newer to mitigate the issue. No workaround other than upgrading has been identified.

References

Community reviews

Loading reviews…