Skip to main content
VulnerabilityPublished

CVE-2026-61438: PraisonAI vulnerable to Remote Code Execution via Broken AST Sandbox

Affects praisonaiSource GCVE Database

0
Compare
Authoritative record:CVE-2026-61438· High 7.0

Not known to be exploited · CVSS 7.0 High : upgrade to 4.6.78 soon.

Data as of 29 Oct 2026, 18:38 UTC

CVSS 4.0 base score
7.0High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 23% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.6.78
CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade praisonai to 4.6.78.

Affected software

ProductAffectedFixed in
PyPIpraisonaiAffected
  • <4.6.78
Fixed in
  • 4.6.78

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in PraisonAI version 4.6.78 that removes the 'os' module from the allowed import list and restricts imports to safe submodules like 'os.path'. Users should upgrade to version 4.6.78 or later to remediate this vulnerability. Until patched, avoid enabling PRAISONAI_ALLOW_JOB_WORKFLOWS=true in environments where untrusted workflows may be executed. The vendor advisory confirms the fix in 4.6.78.

Description

PraisonAI versions prior to 4.6.78 contain a vulnerability in the JobWorkflowExecutor._exec_inline_python() function that allows remote code execution. The vulnerability arises because the sandbox intended to safely execute inline Python expressions is broken: the 'os' module is allowed to be imported, and dangerous functions like os.system() can be called. This enables an attacker to execute arbitrary OS commands with the privileges of the user running the workflow, particularly in multi-tenant or CI environments where untrusted YAML workflows may be executed.

References

Community reviews

Loading reviews…