Skip to main content
VulnerabilityPublished

CVE-2026-120338: Prefab UI's Generative UI sandbox runs caller-supplied Python inside Pyodide, Python compiled to

Affects prefab-uiSource GCVE Database

0
Compare
Authoritative record:CVE-2026-120338· Critical 10.0

Not known to be exploited · CVSS 10.0 Critical · fixed in 0.21.0 : patch prefab-ui as a priority.

Data as of 1 Nov 2026, 19:01 UTC

CVSS 3.1 base score
10.0Critical
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (JFROG)CVSS 3.110.0
CNA (JFROG)CVSS 3.19.9
Patch
Available – fixed in 0.21.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
PyPIprefab-uipkg:pypi/prefab-uiOther threatsAffected
  • >=0.14.0 <=0.20.2
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Prefab UI to version 0.21.0 or later, where the vulnerability is fixed by revoking Deno permissions before executing caller-supplied code, disabling permission prompts, and restricting network access. If upgrading is not immediately possible, disable the Generative UI feature or restrict access to trusted users only. The fix is implemented in commit 030f074 (pull request 538).

Description

Prefab UI's Generative UI sandbox allowed execution of caller-supplied Python code with excessive permissions in Deno subprocesses, enabling arbitrary file read/write and persistent code execution on the server. This affected versions from 0.14.0 through 0.20.2. The vulnerability was fixed in version 0.21.0 by revoking Deno permissions before code execution and restricting network access.

References

Community reviews

Loading reviews…