CVE-2026-112394: Prior to 13.0.0, Pillow's P;2L and P;4L raw decoders can read past the end of an input buffer
Affects pillowSource GCVE Database
Not known to be exploited · CVSS 6.3 Medium : upgrade to 13.0.0 when convenient.
Data as of 27 Oct 2026, 11:14 UTC
- Patch
- Available – fixed in 13.0.0
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:L/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 19 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade pillow to 13.0.0.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
PyPIpillowpkg:pypi/pillowOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Pillow to version 13.0.0 or later, where this vulnerability is fixed. The patch is available and should be applied to prevent exploitation. No other mitigation is indicated or required.
Description
Pillow, a Python imaging library, has a vulnerability in versions prior to 13.0.0 where its P;2L and P;4L raw decoders can read beyond the end of an input buffer. This flaw allows disclosure of up to three adjacent heap bytes or can cause a crash. The issue arises because the unpackers read padded bit planes separately, potentially exceeding the buffer size calculated by ImagingRawDecode. This vulnerability is fixed in version 13.0.0.