Skip to main content
CVE-2026-59927VulnerabilityPublished Updated

src/mistune/directives/include.py detects only direct self-includes · Prior to 3.3.0, the Include directive

Affects mistuneSource GCVE Database

0
Authoritative record:CVE-2026-59927· Medium 5.3

Not known to be exploited · CVSS 5.3 Medium · fixed in 1.4.0_6 : update mistune when convenient.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.1 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 44% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.4.0_6, 5.1.2_4
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade adr-viewer to 1.4.0_6; recon-ng to 5.1.2_4.

Affected software

ProductAffectedFixed in
Ubuntu 16.04 LTSmistunepkg:deb/ubuntu/mistune?arch=source&distro=xenialOther threatsAffected
  • =0.6-2
  • =0.7.1-1
Fixed in–
Ubuntu 18.04 LTSmistunepkg:deb/ubuntu/mistune?arch=source&distro=bionicOther threatsAffected
  • 0.7.4-1 – 0.8.3-2
4 affected builds
Fixed in–
Ubuntu 20.04 LTSmistunepkg:deb/ubuntu/mistune?arch=source&distro=focalOther threatsAffected
  • =0.8.4-1
  • =0.8.4-2
Fixed in–
Ubuntu 22.04 LTSmistunepkg:deb/ubuntu/mistune?arch=source&distro=jammyOther threatsAffected
  • =0.8.4-4
  • =0.8.4-5
  • =2.0.0-1+really0.8.4-1
Fixed in–
Ubuntu 24.04 LTSmistunepkg:deb/ubuntu/mistune?arch=source&distro=nobleOther threatsAffected
  • =2.0.4-2
  • =3.0.2-1
Fixed in–
Ubuntu 25.10mistunepkg:deb/ubuntu/mistune?arch=source&distro=questingOther threatsAffected
  • =3.0.2-2
  • =3.1.3-1
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in mistune versions 1.4.0_6 and 5.1.2_4 that addresses this vulnerability by tracking included files to prevent recursive inclusion cycles. Users should upgrade to these fixed versions or later to remediate the issue.

Description

CVE-2026-59927 is a medium severity vulnerability in the mistune markdown renderer's Include directive. It allows uncontrolled recursion through mutual inclusion of markdown files, leading to unbounded recursion and a Python RecursionError that crashes the renderer, causing denial of service. The vulnerability occurs because the directive detects only direct self-inclusion but not indirect inclusion cycles. A patch is available that fixes this issue by tracking included files to prevent recursive cycles.

References

Community reviews

Loading reviews…