Skip to main content
CVE-2026-59818VulnerabilityPublished

Prior to 3.5.32 and 3.6.13, when etcd is configured with --listen-client-http-urls to split HTTP and gRPC client

Affects etcdSource GCVE Database

0
Authoritative record:CVE-2026-59818· Medium 6.5

Not known to be exploited · CVSS 6.5 Medium · fixed in 3.7.1 : update etcd when convenient.

Data as of 26 Oct 2026, 10:12 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 36% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Affects
etcd prior to 3.5.32
Patch
Available – fixed in 3.7.1
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 26.10etcdpkg:deb/ubuntu/etcd?arch=source&distro=stonkingOther threatsAffected
  • =3.5.16-10
  • =3.5.30-2
Fixed in–
Ubuntu Pro 26.04 LTSetcdpkg:deb/ubuntu/etcd?arch=source&distro=esm-apps/resoluteOther threatsAffected
  • =3.5.16-4
  • =3.5.16-10
  • =3.5.16-10ubuntu0.26.04.1~esm1
Fixed in–
Ubuntu 25.10etcdpkg:deb/ubuntu/etcd?arch=source&distro=questingOther threatsAffected
  • =3.5.16-4
Fixed in–
Ubuntu Pro 24.04 LTSetcdpkg:deb/ubuntu/etcd?arch=source&distro=esm-apps/nobleOther threatsAffected
  • 3.4.23-4ubuntu2 – 3.4.30-1ubuntu0.24.04.3+esm2
9 affected builds
Fixed in–
Ubuntu Pro 22.04 LTSetcdpkg:deb/ubuntu/etcd?arch=source&distro=esm-apps/jammyOther threatsAffected
  • 3.3.25+dfsg-6 – 3.3.25+dfsg-7ubuntu0.22.04.2+esm3
8 affected builds
Fixed in–
Ubuntu Pro 20.04 LTSetcdpkg:deb/ubuntu/etcd?arch=source&distro=esm-apps/focalOther threatsAffected
  • 3.2.26+dfsg-3 – 3.2.26+dfsg-6ubuntu0.2+esm1
6 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in etcd version 3.7.1-0.1.hum1 as released by Red Hat. Users should update to this version or later. Additionally, restrict network access to the etcd TLS listener to trusted clients only and configure firewall rules to limit inbound connections to authorized hosts on the etcd client port (default 2379) and peer port (default 2380). These mitigations reduce the attack surface and prevent untrusted network attackers from exploiting the vulnerability.

Description

CVE-2026-59818 is a denial of service vulnerability in etcd versions prior to 3.5.32 and 3.6.13. Remote attackers can exhaust memory by opening many TCP connections to the etcd TLS listener without completing the TLS handshake, causing unbounded goroutine creation and resource exhaustion. This leads to denial of service for the etcd cluster and the Kubernetes control plane it supports. Red Hat has released an update including etcd version 3.7.1-0.1.hum1 to address this issue. Mitigations include restricting network access to trusted clients and configuring firewall rules to limit inbound connections. No known exploits are reported in the wild at this time.

References

Community reviews

Loading reviews…