Skip to main content
Report · AWS Security BulletinsAbout CVE-2025-12967Published

Privilege Escalation in Aurora PostgreSQL using AWS JDBC Wrapper, AWS Go Wrapper, AWS NodeJS Wrapper, AWS Python Wrapper, AWS PGSQL ODBC driver

Affects aws-jdbc-wrapperSource AWS Security Bulletins

0
Compare
Authoritative record:CVE-2025-12967· High 8.6

Not known to be exploited · CVSS 8.6 High · fixed in 2.6.5 : patch aws-jdbc-wrapper soon.

Data as of 5 Nov 2026, 23:23 UTC

CVSS 4.0 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.7% chance of exploitation in 30 days – higher than 56% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.6.5, 2.0.1, 1.4.0 +1
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Nov 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Mavencom.amazonaws/aws-jdbc-wrapperpkg:maven/com.amazonaws/aws-jdbc-wrapperOther threatsAffected
  • <2.6.5
Fixed in
  • 2.6.5
npmaws-nodejs-wrapperpkg:npm/aws-nodejs-wrapperOther threatsAffected
  • <2.0.1
Fixed in
  • 2.0.1
PyPIaws-python-wrapperpkg:pypi/aws-python-wrapperOther threatsAffected
  • <1.4.0
Fixed in
  • 1.4.0
npmaws-pgsql-odbc-driverpkg:npm/aws-pgsql-odbc-driverOther threatsAffected
  • <1.0.1
Fixed in
  • 1.0.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

AWS has released official fixes for this vulnerability. Users should upgrade to the following versions or later: AWS JDBC Wrapper v2.6.5, AWS Go Wrapper 2025-10-17, AWS NodeJS Wrapper v2.0.1, AWS Python Wrapper v1.4.0, and AWS PGSQL ODBC driver v1.0.1. As a temporary workaround, removing the public schema from the search path can reduce exposure. Patch status is confirmed fixed by AWS.

Description

Bulletin ID: AWS-2025-028 Scope: AWS Content Type: Important (requires attention) Publication Date: 2025/11/10 10:15 AM PDT Description: Amazon Aurora PostgreSQL a fully managed relational database engine that's compatible with PostgreSQL. We identified CVE-2025-12967, an issue in AWS Wrappers for Amazon Aurora PostgreSQL may allow for privilege escalation to rds_superuser role. A low privilege authenticated user can create a crafted function that could be executed with permissions of other Amazon Relational Database Service (RDS) users. Impacted versions: - AWS JDBC Wrapper <2.6.5 - AWS Go Wrapper <2025-10-17 - AWS NodeJS Wrapper <2.0.1 - AWS Python Wrapper <1.4.0 - AWS ODBC driver <1.0.1

References

Community reviews

Loading reviews…