CVE-2026-120060: server data · PsqlODBC Trusts Counts and Lengths
Source GCVE Database
Not known to be exploited · CVSS 5.9 Medium : upgrade to 18.00.0006 when convenient.
Data as of 2 Nov 2026, 23:28 UTC
Thin evidence
One scorer or none| CNA (PostgreSQL) | CVSS 3.1 | 5.9 |
|---|
- Patch
- Available – fixed in 18.00.0006
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 2 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.
What to do
Upgrade psqlODBC to 18.00.0006.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| PostgreSQLpsqlODBC | Affected
| Fixed in
|
GitHubpsqlODBCpkg:github/psqlODBCOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade psqlODBC to version 18.00.0006 or later where these issues are fixed. No other mitigation or temporary workaround is indicated. Since the vulnerability arises from trusting server data, ensure connections are made only to trusted servers and use appropriate SSL settings.
Description
CVE-2026-120060 is a vulnerability in psqlODBC versions before 18.00.0006 where the client trusts server-supplied counts and lengths in multiple places. This can lead to out-of-bounds reads or client crashes when interacting with a malicious or untrusted server, particularly under certain SSL settings.