Skip to main content
VulnerabilityPublished Updated

CVE-2026-41312: pypdf · Manipulated FlateDecode predictor parameters can exhaust RAM

Affects pdflySource GCVE Database

0
Authoritative record:CVE-2026-41312· Medium 4.8

Not known to be exploited · CVSS 4.8 Medium : upgrade to 0.5.1_17 when convenient.

Data as of 26 Oct 2026, 18:58 UTC

CVSS 4.0 base score
4.8Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 0.5.1_17
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade pdfly to 0.5.1_17.

Affected software

ProductAffectedFixed in
Homebrewpdflypkg:brew/pdflyOther threatsAffected
  • >=0.4.0 <0.5.1_17
Fixed in
  • 0.5.1_17

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

### Impact An attacker who uses this vulnerability can craft a PDF which leads to the RAM being exhausted. This requires accessing a stream compressed using `/FlateDecode` with a `/Predictor` unequal 1 and large predictor parameters. ### Patches This has been fixed in [pypdf==6.10.2](https://github.com/py-pdf/pypdf/releases/tag/6.10.2). ### Workarounds If you cannot upgrade yet, consider applying the changes from PR [#3734](https://github.com/py-pdf/pypdf/pull/3734).

References

Community reviews

Loading reviews…