Skip to main content
CVE-2026-59938VulnerabilityPublished

Pypdf2: Prior to 6.14.0, an attacker can craft a PDF with declared image size values that are much too large compared

Affects pypdf2Source GCVE Database

0
Authoritative record:CVE-2026-59938· Medium 6.9

Not known to be exploited · CVSS 6.9 Medium · fixed in 0.5.1_23 : update pypdf2 when convenient.

Data as of 26 Oct 2026, 10:12 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 43% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Affects
pypdf2 prior to 6.14.0
Patch
Available – fixed in 0.5.1_23, 3.3.15_3
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade pdfly to 0.5.1_23; psutils to 3.3.15_3.

Affected software

ProductAffectedFixed in
Ubuntu Pro 16.04 LTSpypdf2pkg:deb/ubuntu/pypdf2?arch=source&distro=esm-apps/xenialOther threatsAffected
  • 1.23+git20141008-1 – 1.25.1-1ubuntu0.1~esm2
4 affected builds
Fixed in–
Ubuntu Pro 18.04 LTSpypdf2pkg:deb/ubuntu/pypdf2?arch=source&distro=esm-apps/bionicOther threatsAffected
  • =1.26.0-2
  • =1.26.0-2ubuntu0.1~esm1
  • =1.26.0-2ubuntu0.1~esm2
Fixed in–
Ubuntu 20.04 LTSpypdf2pkg:deb/ubuntu/pypdf2?arch=source&distro=focalOther threatsAffected
  • 1.26.0-2 – 1.26.0-3ubuntu1.20.04.2
4 affected builds
Fixed in–
Ubuntu 22.04 LTSpypdf2pkg:deb/ubuntu/pypdf2?arch=source&distro=jammyOther threatsAffected
  • =1.26.0-4
  • =1.26.0-4ubuntu0.22.04.1
  • =1.26.0-4ubuntu0.22.04.2
Fixed in–
Ubuntu 24.04 LTSpypdfpkg:deb/ubuntu/pypdf?arch=source&distro=nobleOther threatsAffected
  • 3.4.1-1 – 4.0.2-1
5 affected builds
Fixed in–
Ubuntu 24.04 LTSpypdf2pkg:deb/ubuntu/pypdf2?arch=source&distro=nobleOther threatsAffected
  • =2.12.1-3
  • =2.12.1-4
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade to pypdf version 6.14.0 or later, where the vulnerability is fixed. If upgrading is not immediately possible, apply the changes from pull request #3888 as a workaround to mitigate the issue.

Description

CVE-2026-59938 is a vulnerability in pypdf2 versions prior to 6.14.0 where an attacker can craft a PDF with image size declarations that are much larger than the actual image data, causing excessive memory usage during processing. This issue has been fixed in pypdf version 6.14.0. A workaround is available by applying changes from pull request #3888 if immediate upgrading is not possible.

References

Community reviews

Loading reviews…