Pypdf2: Prior to 6.14.0, an attacker can craft a PDF with repeated malformed cross-reference streams that cause pypdf
Affects pypdf2Source GCVE Database
Not known to be exploited · CVSS 6.9 Medium · fixed in 0.5.1_23 : update pypdf2 when convenient.
Data as of 26 Oct 2026, 10:12 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 49% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.5.1_23, 3.3.15_3
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 8 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade pdfly to 0.5.1_23; psutils to 3.3.15_3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu Pro 16.04 LTSpypdf2pkg:deb/ubuntu/pypdf2?arch=source&distro=esm-apps/xenialOther threats | Affected
| Fixed in– |
Ubuntu Pro 18.04 LTSpypdf2pkg:deb/ubuntu/pypdf2?arch=source&distro=esm-apps/bionicOther threats | Affected
| Fixed in– |
Ubuntu 20.04 LTSpypdf2pkg:deb/ubuntu/pypdf2?arch=source&distro=focalOther threats | Affected
| Fixed in– |
Ubuntu 22.04 LTSpypdf2pkg:deb/ubuntu/pypdf2?arch=source&distro=jammyOther threats | Affected
| Fixed in– |
Ubuntu 24.04 LTSpypdfpkg:deb/ubuntu/pypdf?arch=source&distro=nobleOther threats | Affected
| Fixed in– |
Ubuntu 24.04 LTSpypdf2pkg:deb/ubuntu/pypdf2?arch=source&distro=nobleOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade pypdf2 to version 6.14.0 or later, where the vulnerability is fixed. If upgrading immediately is not possible, apply the changes from the referenced pull request to mitigate the issue.
Description
Pypdf2 versions prior to 6.14.0 have a vulnerability where specially crafted PDFs with repeated malformed cross-reference streams cause excessive processing time, potentially leading to denial of service. This issue has been fixed in version 6.14.0. If upgrading is not possible immediately, applying the referenced pull request changes is recommended.
References
- ubuntu.com/security/CVE-2026-59937 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-59937 (opens in a new tab)
- github.com/py-pdf/pypdf/security/advisories/GHSA-55h5-xmcq-c37v (opens in a new tab)
- github.com/py-pdf/pypdf/pull/3887 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-59937 (opens in a new tab)
- github.com/py-pdf/pypdf/commit/b5fc5aa714f4b696fb9b1deaa35a9e4a4eb50dae (opens in a new tab)
- github.com/py-pdf/pypdf (opens in a new tab)
- github.com/py-pdf/pypdf/releases/tag/6.14.0 (opens in a new tab)