CVE-2024-6345: Pyqt builder · setuptools vulnerable to Command Injection via package URL
Affects pyqt-builderSource GCVE Database
Not known to be exploited · CVSS 8.8 High : upgrade to 1.16.3 soon.
Data as of 26 Oct 2026, 17:16 UTC
- EPSS
- 1.9% chance of exploitation in 30 days – higher than 79% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.16.3
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 15 Jul 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade pyqt-builder to 1.16.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewpyqt-builderpkg:brew/pyqt-builderOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and should be applied immediately. Users should upgrade setuptools to version 70.0 or later and pyqt-builder to version 1.16.3 or later to remediate this vulnerability. No other mitigations are indicated by the vendor advisory.
Description
CVE-2024-6345 is a high-severity vulnerability in the package_index module of pypa/setuptools up to version 69.1.1. It allows remote code execution via command injection through download functions that handle package URLs. This flaw can be exploited if these functions process user-controlled URLs, leading to arbitrary command execution on the affected system. The issue is fixed in setuptools version 70.0 and pyqt-builder versions 1.16.3 and later.
References
- nvd.nist.gov/vuln/detail/CVE-2024-6345 (opens in a new tab)
- github.com/pypa/setuptools/pull/4332 (opens in a new tab)
- github.com/pypa/setuptools/commit/88807c7062788254f654ea8c03427adc859321f0 (opens in a new tab)
- github.com/pypa/setuptools (opens in a new tab)
- huntr.com/bounties/d6362117-ad57-4e83-951f-b8141c6e7ca5 (opens in a new tab)
- lists.debian.org/debian-lts-announce/2024/09/msg00018.html (opens in a new tab)