Skip to main content
CVE-2026-32773VulnerabilityPublished Updated

Pyspark: Apache Spark History Server allows stored cross-site scripting through unescaped application names

Affects pysparkSource GCVE Database

0
Authoritative record:CVE-2026-32773· Medium 6.1

Not known to be exploited · CVSS 6.1 Medium : upgrade to 3.5.8 when convenient.

Data as of 26 Oct 2026, 12:55 UTC

CVSS 3.1 base score
6.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 35% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.5.8
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade pyspark and org.apache.spark:spark-core_2.12 and org.apache.spark:spark-core_2.13 to 3.5.8.

Affected software

ProductAffectedFixed in
PyPIpysparkAffected
  • >=3.0.0 <3.5.8
Fixed in
  • 3.5.8
Mavenorg.apache.spark:spark-core_2.12Affected
  • >=3.0.0 <3.5.8
Fixed in
  • 3.5.8
Mavenorg.apache.spark:spark-core_2.13Affected
  • >=3.0.0 <3.5.8
Fixed in
  • 3.5.8

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

There is a lack of XSS escaping in the Spark History Server prior to 3.5.8 which allows a malicious Spark job to generate arbitrary unescaped frontend code which could lead to a minimal privilege escalation in browser. Users are encouraged to upgrade to Spark 3.5.8 or later. This CVE is marked as "low" since the path to exploit requires both relatively high permissions (ability to launch a Spark job) and requires tricking a user with higher permissions to log in and visit the Spark history web page. Users are encouraged to upgrade their Spark history servers to Spark 3.5.8 or later.

References

Community reviews

Loading reviews…