CVE-2026-111497: python-brotlicffi security update
Affects Google python-brotlicffiSource GCVE Database
Exploited in the wild · KEV due 10 Nov 2026 · 87% EPSS : upgrade to 1.1.0.0-2.oe2403sp4 now.
Data as of 29 Oct 2026, 10:50 UTC
Thin evidence
One scorer or none| CNA (Google) | CVSS 4.0 | 9.2 |
|---|
- KEV deadline
- US federal agencies must patch by this date; a sensible deadline for everyone else. Other KEV due dates
- EPSS
- 87.9% chance of exploitation in 30 days – higher than 99% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.1.0.0-2.oe2403sp4
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
t = 0 is the CVE’s publication on cve.org
Disclosed: evidence found.
CVE published 22 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: evidence found.
Listed in CISA KEV 5 days after disclosure
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
Timeline
CVE ID reserved
by Google LLC
, 6 days before disclosure
CVE published
on cve.org
, t = 0
In Threat Radar
record ingested
, 4 days after disclosure
Added to CISA KEV (opens in a new tab)
exploitation confirmed
, 5 days after disclosure
KEV remediation due
US federal deadline
, 19 days after disclosure
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CISA KEV (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade Google python-brotlicffi to 1.1.0.0-2.oe2403sp4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
openEuler 24.03-LTS-SP4python-brotlicffipkg:rpm/openEuler/python-brotlicffi&distro=openEuler-24.03-LTS-SP4Other threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
Description
A critical buffer overflow vulnerability exists in the Brotli decoder used by python-brotlicffi versions prior to 1.1.0.0-2.oe2403sp4. This flaw allows a remote unauthenticated attacker to corrupt memory, potentially leading to sensitive data disclosure, denial of service, or arbitrary code execution via a crafted Brotli-compressed stream. Users should update to fixed versions 1.1.0.0-2.oe2403sp4 or later to mitigate the risk.