Skip to main content
VulnerabilityPublished

CVE-2026-111497: python-brotlicffi security update

Affects Google python-brotlicffiSource GCVE Database

0
Compare
Authoritative record:CVE-2026-111497· Critical 9.2

Exploited in the wild · KEV due 10 Nov 2026 · 87% EPSS : upgrade to 1.1.0.0-2.oe2403sp1 now.

Data as of 29 Oct 2026, 10:50 UTC

CVSS 4.0 base score
9.2Critical
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (Google)CVSS 4.09.2
KEV deadline
 US federal agencies must patch by this date; a sensible deadline for everyone else. Other KEV due dates
EPSS
87.9% chance of exploitation in 30 days – higher than 99% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.1.0.0-2.oe2403sp1
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

t = 0 is the CVE’s publication on cve.org

  1. Disclosed: evidence found.

    CVE published 22 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: evidence found.

    Listed in CISA KEV 5 days after disclosure

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

Timeline

  1. CVE ID reserved

    by Google LLC

    , 6 days before disclosure

  2. CVE published

    on cve.org

    , t = 0

  3. In Threat Radar

    record ingested

    , 4 days after disclosure

  4. , 5 days after disclosure

  5. KEV remediation due

    US federal deadline

    , 19 days after disclosure

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CISA KEV (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade Google python-brotlicffi to 1.1.0.0-2.oe2403sp1.

Affected software

ProductAffectedFixed in
openEuler 24.03-LTS-SP1python-brotlicffipkg:rpm/openEuler/python-brotlicffi&distro=openEuler-24.03-LTS-SP1Other threatsAffected
  • <1.1.0.0-2.oe2403sp1
Fixed in
  • 1.1.0.0-2.oe2403sp1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

A buffer overflow vulnerability exists in the Brotli decoder used by python-brotlicffi, affecting Google Brotli versions 1.0.3 through 1.2.0. This flaw allows remote unauthenticated attackers to corrupt adjacent memory, potentially disclosing sensitive information, causing denial of service, or executing arbitrary code. The issue is fixed in version 1.1.0.0-2.oe2403sp1 and later.

References

Community reviews

Loading reviews…