Skip to main content
VulnerabilityPublished Updated

CVE-2024-24762: python-multipart vulnerabilities

Affects python-multipartSource GCVE Database

0

Mentioned vulnerabilities

Not known to be exploited · fixed in 0.0.5-2ubuntu0.1~esm1 : update python-multipart when convenient.

Data as of 27 Oct 2026, 06:42 UTC

Severity
Unrated

Rated by Threat Radar · No CVSS score from NVD or the CNA

Patch
Available – fixed in 0.0.5-2ubuntu0.1~esm1, 0.0.9-1ubuntu0.1~esm1

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Ubuntu python-multipart to 0.0.5-2ubuntu0.1~esm1 (package) or 0.0.9-1ubuntu0.1~esm1 (package).

Affected software

ProductAffectedFixed in
Ubuntu Pro 24.04 LTSpython-multipartpkg:deb/ubuntu/python-multipart?arch=source&distro=esm-apps/nobleOther threatsAffected
  • <0.0.9-1ubuntu0.1~esm1
Fixed in
  • 0.0.9-1ubuntu0.1~esm1
Ubuntu Pro 22.04 LTSpython-multipartpkg:deb/ubuntu/python-multipart?arch=source&distro=esm-apps/jammyOther threatsAffected
  • <0.0.5-2ubuntu0.1~esm1
Fixed in
  • 0.0.5-2ubuntu0.1~esm1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

It was discovered that Python-Multipart incorrectly handled certain regular expressions. An attacker could possibly use this issue to cause Python-Multipart to consume excessive resources, leading to a regular expression denial of service. This issue only affected Ubuntu 22.04 LTS. (CVE-2024-24762) It was discovered that Python-Multipart did not properly sanitize line breaks during user input. An attacker could use this issue to send arbitrary input, thus preventing other requests from being processed, resulting in a denial of service. This issue was only fixed in Ubuntu 24.04 LTS. (CVE-2024-53981) It was discovered that Python-Multipart was vulnerable to path traversal attacks. An attacker could possibly craft and upload files outside the target directory, resulting in remote code execution. (CVE-2026-24486)

References

Community reviews

Loading reviews…