Python@3.11: setuptools has a path traversal vulnerability in PackageIndex.download that leads to Arbitrary File Write
Affects python@3.11Source GCVE Database
Public exploit available · CVSS 8.7 High : upgrade to 3.11.12_1 as a priority.
Data as of 26 Oct 2026, 19:42 UTC
- Patch
- Available – fixed in 3.11.12_1
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N/E:PExploitation evidence
Disclosed: evidence found.
CVE published 13 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: evidence found.
CVSS exploit maturity: proof of concept public
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade python@3.11 to 3.11.12_1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewpython@3.11pkg:brew/python%403.11Other threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in Python 3.11.12_1 which fixes this vulnerability. Users should upgrade to this version or later to remediate the issue. Since the vulnerability is fixed, no additional mitigation steps are required.
Description
A path traversal vulnerability in setuptools' PackageIndex.download function allows an attacker to write files to arbitrary filesystem locations. This flaw arises from insufficient sanitization of URL-derived filenames, enabling os.path.join to be bypassed. The vulnerability affects Python 3.11 versions from 3.11.0 up to but not including 3.11.12_1. A fix is available in version 3.11.12_1. Exploitation could lead to arbitrary file write with the permissions of the running process, potentially escalating to remote code execution depending on context.
References
- github.com/pypa/setuptools/security/advisories/GHSA-5rjg-fvgr-3xxf (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2025-47273 (opens in a new tab)
- github.com/pypa/setuptools/issues/4946 (opens in a new tab)
- github.com/pypa/setuptools/commit/250a6d17978f9f6ac3ac887091f2d32886fbbb0b (opens in a new tab)
- github.com/pypa/advisory-database/tree/main/vulns/setuptools/PYSEC-2025-49.yaml (opens in a new tab)
- github.com/pypa/setuptools (opens in a new tab)
- github.com/pypa/setuptools/blob/6ead555c5fb29bc57fe6105b1bffc163f56fd558/setuptools/package_index.py (opens in a new tab)
- lists.debian.org/debian-lts-announce/2025/05/msg00035.html (opens in a new tab)