CVE-2024-31580: PyTorch before v2.2.0 was discovered to contain a heap buffer overflow vulnerability in the component /runtime/vararg_functions.cpp
Affects pytorchSource GCVE Database
Not known to be exploited : upgrade to 2.2.1 when convenient.
Data as of 26 Oct 2026, 17:16 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 13% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.2.1
Exploitation evidence
Disclosed: evidence found.
CVE published 11 Jun 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade pytorch to 2.2.1.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Bitnamipytorchpkg:bitnami/pytorchOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade PyTorch to version 2.2.1 or later, where this heap buffer overflow vulnerability has been patched. Refer to the official patch commit for details: https://github.com/pytorch/pytorch/commit/b5c3a17c2c207ebefcb85043f0cf94be9b2fef81
Description
PyTorch versions prior to 2.2.1 contain a heap buffer overflow vulnerability in the /runtime/vararg_functions.cpp component. This flaw can be triggered by crafted input to cause a Denial of Service (DoS) condition. A patch addressing this vulnerability is available.