Pytorch: setuptools has a path traversal vulnerability in PackageIndex.download that leads to Arbitrary File Write
Affects pytorchSource GCVE Database
Public exploit available · CVSS 8.7 High : upgrade to 2.8.0 as a priority.
Data as of 31 Oct 2026, 16:06 UTC
- Patch
- Available – fixed in 2.8.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N/E:PExploitation evidence
Disclosed: evidence found.
CVE published 13 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
CVSS exploit maturity: proof of concept public
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade pytorch to 2.8.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewpytorchpkg:brew/pytorchOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in PyTorch version 2.8.0 which includes the patched setuptools version 78.1.1. Users should upgrade to version 2.8.0 or later to remediate this vulnerability. Since patchAvailable is true and fixedVersions includes 2.8.0, applying this official fix fully mitigates the issue.
Description
A path traversal vulnerability in setuptools' PackageIndex.download function allows an attacker to write files to arbitrary filesystem locations with the permissions of the running Python process. This flaw arises from insufficient sanitization of URL-derived filenames, enabling path traversal despite some replacement of '..' sequences. The vulnerability affects PyTorch versions from 2.2.0 up to but not including 2.8.0 and was fixed in version 2.8.0. Exploitation could lead to arbitrary file write and potentially remote code execution depending on the environment.
References
- github.com/pypa/setuptools/security/advisories/GHSA-5rjg-fvgr-3xxf (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2025-47273 (opens in a new tab)
- github.com/pypa/setuptools/issues/4946 (opens in a new tab)
- github.com/pypa/setuptools/commit/250a6d17978f9f6ac3ac887091f2d32886fbbb0b (opens in a new tab)
- github.com/pypa/advisory-database/tree/main/vulns/setuptools/PYSEC-2025-49.yaml (opens in a new tab)
- github.com/pypa/setuptools (opens in a new tab)
- github.com/pypa/setuptools/blob/6ead555c5fb29bc57fe6105b1bffc163f56fd558/setuptools/package_index.py (opens in a new tab)
- lists.debian.org/debian-lts-announce/2025/05/msg00035.html (opens in a new tab)