Skip to main content
CVE-2025-3121VulnerabilityPublished Updated

CVE-2025-3121: PyTorch torch.jit.jit_module_from_flatbuffer memory corruption

Affects pytorchSource GCVE Database

0

Not known to be exploited : upgrade to 2.7.0 when convenient.

Data as of 25 Oct 2026, 19:02 UTC

Severity
Medium

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.2% chance of exploitation in 30 days – higher than 19% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.7.0

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 May 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade pytorch to 2.7.0.

Affected software

ProductAffectedFixed in
Bitnamipytorchpkg:bitnami/pytorchOther threatsAffected
  • >=2.6.0 <2.7.0
Fixed in
  • 2.7.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available for this vulnerability. Users should update PyTorch to a fixed version beyond 2.6.0 to remediate the issue. No additional mitigation guidance is provided or required.

Description

A memory corruption vulnerability exists in PyTorch version 2.6.0 in the function torch.jit.jit_module_from_flatbuffer. Exploitation requires local access. The vulnerability has been publicly disclosed and a patch is available. The severity is assessed as medium.

References

Community reviews

Loading reviews…