CVE-2025-3000: PyTorch torch.jit.script memory corruption
Affects pytorchSource GCVE Database
Not known to be exploited : upgrade to 2.7.0 when convenient.
Data as of 26 Oct 2026, 11:42 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 10% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.7.0
Exploitation evidence
Disclosed: evidence found.
CVE published 30 May 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade pytorch to 2.7.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Bitnamipytorchpkg:bitnami/pytorchOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available for this vulnerability. Users should upgrade PyTorch to version 2.7.0 or later to mitigate the risk. Since the vulnerability requires local access, limiting access to trusted users and environments can reduce exposure until patched.
Description
A critical vulnerability in PyTorch 2.6.0 affecting the torch.jit.script function can lead to memory corruption. The vulnerability can be exploited locally. Although the exploit has been publicly disclosed, no known exploits are reported in the wild. A patch is available to address this issue.