CVE-2025-2999: PyTorch torch.nn.utils.rnn.unpack_sequence memory corruption
Affects pytorchSource GCVE Database
Not known to be exploited : upgrade to 2.7.0 when convenient.
Data as of 26 Oct 2026, 12:55 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 10% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.7.0
Exploitation evidence
Disclosed: evidence found.
CVE published 30 May 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade pytorch to 2.7.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Bitnamipytorchpkg:bitnami/pytorchOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available for this vulnerability. Users should upgrade PyTorch to version 2.7.0 or later to remediate the issue. Since this is not a cloud service, remediation is the responsibility of the user. No additional mitigation steps are indicated by the vendor advisory.
Description
A critical vulnerability exists in PyTorch version 2.6.0 through versions before 2.7.0 in the function torch.nn.utils.rnn.unpack_sequence. This flaw can lead to memory corruption when exploited locally. The vulnerability has been publicly disclosed, but no known exploits are reported in the wild. A patch is available to address this issue.