CVE-2025-23050: Qt · QLowEnergyController
Source GCVE Database
Not known to be exploited · CVSS 3.1 Low · fixed in 6.8.2 : update Qt when convenient.
Data as of 29 Oct 2026, 23:27 UTC
- Patch
- Available – fixed in 6.8.2, 6.5.9, 5.15.19
CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:LExploitation evidence
Disclosed: evidence found.
CVE published 31 Oct 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade org.qtproject/qt to 6.8.2, 6.5.9 or 5.15.19.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Mavenorg.qtproject/qtpkg:maven/org.qtproject/qtOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade affected Qt versions to 5.15.19, 6.5.9, or 6.8.2 or later where the vulnerability is fixed. No other mitigation or workaround is indicated.
Description
A vulnerability in QLowEnergyController component of Qt before version 6.8.2 allows mishandling of malformed Bluetooth ATT commands, resulting in an out-of-bounds read or division by zero. This flaw has been addressed in Qt versions 5.15.19, 6.5.9, and 6.8.2.