Skip to main content
VulnerabilityPublished Updated

CVE-2026-43725: Qtwebkit opensource src · The issue was addressed with improved input validation

Affects qtwebkit-opensource-srcSource GCVE Database

0
Authoritative record:CVE-2026-43725· High 7.1

Not known to be exploited · CVSS 7.1 High · fixed in 2.52.6-0ubuntu0.24.04.1 : patch qtwebkit-opensource-src soon.

Data as of 26 Oct 2026, 14:05 UTC

CVSS 3.1 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.9% chance of exploitation in 30 days – higher than 59% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.52.6-0ubuntu0.24.04.1, 2.52.6-0ubuntu0.26.04.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Ubuntu webkit2gtk to 2.52.6-0ubuntu0.24.04.1 (package) or 2.52.6-0ubuntu0.26.04.1 (package).

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSwebkit2gtkpkg:deb/ubuntu/webkit2gtk?arch=source&distro=resoluteOther threatsAffected
  • <2.52.6-0ubuntu0.26.04.1
Fixed in
  • 2.52.6-0ubuntu0.26.04.1
Ubuntu 24.04 LTSqtwebkit-opensource-srcpkg:deb/ubuntu/qtwebkit-opensource-src?arch=source&distro=nobleOther threatsAffected
  • 5.212.0~alpha4-33 – 5.212.0~alpha4-36
6 affected builds
Fixed in–
Ubuntu 24.04 LTSwebkit2gtkpkg:deb/ubuntu/webkit2gtk?arch=source&distro=nobleOther threatsAffected
  • <2.52.6-0ubuntu0.24.04.1
Fixed in
  • 2.52.6-0ubuntu0.24.04.1
Ubuntu 22.04 LTSqtwebkit-opensource-srcpkg:deb/ubuntu/qtwebkit-opensource-src?arch=source&distro=jammyOther threatsAffected
  • 5.212.0~alpha4-12 – 5.212.0~alpha4-15ubuntu1
6 affected builds
Fixed in–
Ubuntu 22.04 LTSwebkit2gtkpkg:deb/ubuntu/webkit2gtk?arch=source&distro=jammyOther threatsAffected
  • 2.34.0-1ubuntu1 – 2.50.4-0ubuntu0.22.04.1
42 affected builds
Fixed in–
Ubuntu 22.04 LTSwpewebkitpkg:deb/ubuntu/wpewebkit?arch=source&distro=jammyOther threatsAffected
  • 2.32.4-1 – 2.36.0-2ubuntu3
9 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

The issue was addressed with improved input validation. This issue is fixed in Safari 26.5.2, iOS 18.7.10 and iPadOS 18.7.10, iOS 26.5.2 and iPadOS 26.5.2, macOS Tahoe 26.5.2, tvOS 26.6, visionOS 26.6, watchOS 26.6. A malicious website may be able to process restricted web content outside the sandbox.

References

Community reviews

Loading reviews…