Skip to main content
VulnerabilityPublished

CVE-2026-116192: rclone from 1.37 before 1.74.2 SSRF via --rc-serve scheme-relative remote roots

Affects rcloneSource GCVE Database

0
Compare
Authoritative record:CVE-2026-116192· High 8.2

Not known to be exploited · CVSS 8.2 High : upgrade to 1.74.2 soon.

Data as of 29 Oct 2026, 14:41 UTC

CVSS 4.0 base score
8.2High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.08.2
CNA (VulnCheck)CVSS 3.15.9
EPSS
0.2% chance of exploitation in 30 days – higher than 12% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.74.2
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 25 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade rclone to 1.74.2.

Affected software

ProductAffectedFixed in
Bitnamirclonepkg:bitnami/rcloneOther threatsAffected
  • >=1.37.0 <1.74.2
Fixed in
  • 1.74.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade rclone to version 1.74.2 or later, where this SSRF vulnerability is fixed. No other mitigation is indicated by the vendor advisory.

Description

rclone versions from 1.37 up to but not including 1.74.2 contain a server-side request forgery (SSRF) vulnerability. This flaw allows unauthenticated attackers to redirect HTTP and NetStorage backend requests by supplying a double-slash root on an existing named remote via the --rc-serve option. Exploitation enables attackers to make HEAD or GET requests to attacker-controlled hosts, potentially reading responses, capturing configured custom headers, or obtaining valid NetStorage request signatures. The vulnerability is fixed in version 1.74.2.

References

Community reviews

Loading reviews…