Skip to main content
CVE-2025-21171VulnerabilityPublished Updated

SUSE · bugfix update for dotnet9.0

Affects SUSESource GCVE Database

0
Authoritative record:CVE-2025-21171· High 7.5

Not known to be exploited · CVSS 7.5 High · fixed in 9.9 : patch SUSE soon.

Data as of 26 Oct 2026, 07:57 UTC

CVSS base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.7% chance of exploitation in 30 days – higher than 77% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.9, 9.6, 8.11 +1

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Jan 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade SUSE to 9.9, 9.6, 8.11 or 7.5.2.

Affected software

ProductAffectedFixed in
SUSE Product Security Team SUSEAffected
  • >=8.0 <8.11
  • >=9.0 <9.6
  • >=9.6 <9.9
  • >=7.5.0 <7.5.2
Fixed in
  • 8.11
  • 9.6
  • 9.9
  • 7.5.2

AI-suggested

A patch is available and users should apply the updated .NET 9.0 SDK (9.0.102) and Runtime (9.0.1) packages provided by Red Hat as detailed in their advisory (https://access.redhat.com/errata/RHBA-2025:0305). Applying these updates promptly will mitigate the risk posed by this vulnerability.

Description

CVE-2025-21171 is a high-severity remote code execution vulnerability in multiple versions of the .NET 9.0 framework implementation used by PowerShell and related runtimes. The flaw allows remote attackers to execute arbitrary code. Red Hat has released updated .NET SDK and Runtime packages that fix this vulnerability. Users of affected versions are advised to apply these updates promptly to mitigate risk.

References

Community reviews

Loading reviews…