Red Hat Enterprise Linux (libXi, libXrender, ansible-collection-redhat-leapp) und Red Hat Build of Apache Camel for
Affects Bundesamt für Sicherheit in der Informationstechnik ApacheSource GCVE Database
Not known to be exploited · CVSS 7.4 High : upgrade to 1.8.4 soon.
Data as of 29 Oct 2026, 12:04 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 17% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.8.4
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 24 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade libXi and x.org/libxi to 1.8.4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| x.orglibXi | Affected
| Fixed in
|
X.orgx.org/libxipkg:deb/x.org/libxiOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Red Hat has released an official fix in libXi version 4.18. Users should apply the update as detailed in Red Hat Advisory RHSA-2026:91056 to remediate this vulnerability. No additional mitigation steps are required beyond applying the vendor-provided patch.
Description
A denial of service vulnerability exists in the libXi runtime library used by Red Hat Enterprise Linux 9. The flaw involves an out-of-bounds read in the XI2 class parser. This issue affects libXi versions prior to 4.18 and version 4.18 itself has been released as a fix. Red Hat has issued an advisory rating the severity as Moderate and provided updated packages to address the vulnerability.
References
- wid.cert-bund.de/.well-known/csaf/white/2026/wid-sec-w-2026-4187.json (opens in a new tab)
- wid.cert-bund.de/portal/wid/securityadvisory?name=WID-SEC-2026-4187 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:91056 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:91268 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:91057 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:91267 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:91294 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:91304 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:91490 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:91491 (opens in a new tab)
- linux.oracle.com/errata/ELSA-2026-91004.html (opens in a new tab)
- linux.oracle.com/errata/ELSA-2026-91003.html (opens in a new tab)
- linux.oracle.com/errata/ELSA-2026-91612.html (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:91003 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:91004 (opens in a new tab)