Skip to main content
CVE-2025-2487VulnerabilityPublished Updated

SUSE · security update for 389-ds-base

Affects SUSESource GCVE Database

0

Not known to be exploited : upgrade to 9.8.1 or 9.6.1 when convenient.

Data as of 25 Oct 2026, 19:02 UTC

Severity
Medium

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.5% chance of exploitation in 30 days – higher than 48% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.8.1, 9.6.1

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 May 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade redhat/389-ds-base to 9.8.1 or 9.6.1.

Affected software

ProductAffectedFixed in
Red Hatredhat/389-ds-basepkg:rpm/redhat/389-ds-baseOther threatsAffected
  • >=9.0.0 <9.6.1
  • >=9.6.0 <9.6.1
  • >=9.8.0 <9.8.1
Fixed in
  • 9.6.1
  • 9.8.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released updated packages for 389-ds-base that address this vulnerability. Users should apply the security update as described in Red Hat advisory RHSA-2025:7395 to remediate the issue. The advisory provides detailed instructions for applying the update. Since a patch is available, remediation should be performed promptly to prevent denial of service conditions.

Description

A null pointer dereference vulnerability (CVE-2025-2487) exists in 389 Directory Server (389-ds-base), an LDAPv3 compliant server used in Red Hat Enterprise Linux 9. This flaw can cause a denial of service condition. Red Hat has released updated packages addressing this issue with a security advisory rated as moderate severity. The vulnerability affects multiple architectures and variants of Red Hat Enterprise Linux 9. No CVSS score is provided in the advisory.

References

Community reviews

Loading reviews…