Skip to main content
CVE-2024-53920VulnerabilityPublished Updated

Red Hat Security Advisory: A Subscription Management tool for finding and reporting Red Hat product usage

Affects Red HatSource GCVE Database

0
Authoritative record:CVE-2024-53920· High 7.8

Not known to be exploited · CVSS 7.8 High : upgrade the Debian debian/emacs package to 30.1 soon.

Data as of 26 Oct 2026, 11:07 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 48% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 30.1
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Nov 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Debian debian/emacs package to 30.1.

Affected software

ProductAffectedFixed in
Debiandebian/emacspkg:deb/debian/emacsOther threatsAffected
  • <30.1
Fixed in
  • 30.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat advises not to open or view untrusted Emacs Lisp source code files. Disabling elisp-completion-at-point and automatic error checking tools such as Flymake or Flycheck when handling untrusted Emacs Lisp files will mitigate the vulnerability.

Description

In elisp-mode.el in GNU Emacs through 30.0.92, a user who chooses to invoke elisp-completion-at-point (for code completion) on untrusted Emacs Lisp source code can trigger unsafe Lisp macro expansion that allows attackers to execute arbitrary code. (This unsafe expansion also occurs if a user chooses to enable on-the-fly diagnosis that byte compiles untrusted Emacs Lisp source code.)

References

Community reviews

Loading reviews…