Skip to main content
CVE-2024-6126VulnerabilityPublished Updated

SUSE · security update for cockpit

Affects SUSESource GCVE Database

0
Authoritative record:CVE-2024-6126· Low 3.2

Not known to be exploited · CVSS 3.2 Low : upgrade SUSE to 9.5 when convenient.

Data as of 26 Oct 2026, 10:12 UTC

CVSS 3.1 base score
3.2Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 19% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.5
CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:C/C:N/I:N/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Jul 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade SUSE to 9.5.

Affected software

ProductAffectedFixed in
SUSE Product Security Team SUSEAffected
  • >=9.0 <9.5
Fixed in
  • 9.5

AI-suggested

Red Hat has released an official security update as part of Red Hat Enterprise Linux 9.5 that addresses this vulnerability. Users should apply the Red Hat Enterprise Linux 9.5 update or later to remediate this issue. For detailed update instructions, refer to the Red Hat advisory and update documentation. No additional mitigations are indicated by the vendor.

Description

CVE-2024-6126 is a low severity vulnerability in Cockpit, a web-based server administration tool for GNU/Linux. It allows an authenticated user to kill any process when the pam_env module's user_readenv option is enabled. This issue affects Red Hat Enterprise Linux 9 versions prior to 9.5. Red Hat has released a security update as part of the Red Hat Enterprise Linux 9.5 update to address this vulnerability.

References

Community reviews

Loading reviews…