Skip to main content
CVE-2026-45447VulnerabilityPublished Updated

Red Hat Security Advisory: compat-openssl10 security update

Affects Red Hat opensslSource GCVE Database

0

Not known to be exploited · fixed in Ubuntu package updates : patch the affected Ubuntu packages soon.

Data as of 26 Oct 2026, 12:55 UTC

Severity
High

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
4.0% chance of exploitation in 30 days – higher than 90% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.0.1f-1ubuntu2.27+esm14, 1.0.2g-1ubuntu4.20+esm16, 1.1.1-1ubuntu2.1~18.04.23+esm9 +10

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 26.10edk2pkg:deb/ubuntu/edk2?arch=source&distro=stonkingOther threatsAffected
  • 2025.11-3ubuntu7 – 2026.05-2ubuntu3
5 affected builds
Fixed in–
Ubuntu 26.10edk2-hwepkg:deb/ubuntu/edk2-hwe?arch=source&distro=stonkingOther threatsAffected
  • 2025.11-3ubuntu8 – 2026.05-2ubuntu3
5 affected builds
Fixed in–
Ubuntu 26.04 LTSedk2pkg:deb/ubuntu/edk2?arch=source&distro=resoluteOther threatsAffected
  • 2025.02-8ubuntu3 – 2025.11-3ubuntu7.3
5 affected builds
Fixed in–
Ubuntu 26.04 LTSedk2-hwepkg:deb/ubuntu/edk2-hwe?arch=source&distro=resoluteOther threatsAffected
  • =2025.11-3ubuntu6
  • =2025.11-3ubuntu8
  • =2025.11-3ubuntu8.2
Fixed in–
Ubuntu 26.04 LTSopensslpkg:deb/ubuntu/openssl?arch=source&distro=resoluteOther threatsAffected
  • <3.5.5-1ubuntu3.2
Fixed in
  • 3.5.5-1ubuntu3.2
Ubuntu 25.10edk2pkg:deb/ubuntu/edk2?arch=source&distro=questingOther threatsAffected
  • 2025.02-3ubuntu2 – 2025.02-8ubuntu3.2
7 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

The OpenSSL toolkit provides support for secure communications between machines. This version of OpenSSL package contains only the libraries and is provided for compatibility with previous releases and software that does not support compilation with OpenSSL-1.1. Security Fix(es): * openssl: Heap Use-After-Free in OpenSSL PKCS7_verify() (CVE-2026-45447) For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.

Reports on CVE-2026-45447

References

Community reviews

Loading reviews…