Skip to main content
CVE-2024-47076VulnerabilityPublished Updated

Red Hat Security Advisory: cups-filters security update

Affects Red Hat cups-filtersSource GCVE Database

0

Mentioned vulnerabilities

Authoritative record:CVE-2024-47076· High 8.6

Public exploit available (Metasploit) · 79% EPSS · CVSS 8.6 High : upgrade Red Hat cups-filters to 7.7.3 as a priority.

Data as of 26 Oct 2026, 10:12 UTC

CVSS 3.1 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
79.8% chance of exploitation in 30 days – higher than 99% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 7.7.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Sep 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: evidence found.

    1 Metasploit module

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Red Hat cups-filters to 7.7.3.

Affected software

ProductAffectedFixed in
Red Hat Product Security Red HatAffected
  • >=7.7 <7.7.3
Fixed in
  • 7.7.3

AI-suggested

Red Hat has released updated cups-filters packages for Red Hat Enterprise Linux 7.7 that address these vulnerabilities. Users should apply the security update as detailed in Red Hat Advisory RHSA-2024:7551 and the related article https://access.redhat.com/articles/11258 to remediate these issues. No additional mitigation steps are indicated beyond applying the official patches.

Description

Multiple vulnerabilities were identified in the cups-filters package used in Red Hat Enterprise Linux 7.7, including an unsanitized IPP attribute issue in the cfGetPrinterAttributes API (CVE-2024-47076), a trust issue with cups-browsed binding on UDP, and a remote command injection vulnerability via PPD files in cups libppd. These flaws could allow attackers to exploit components of the printing system. Red Hat has released updated packages addressing these issues.

References

Community reviews

Loading reviews…